Basic questions to ask SysAdmin candidates to shake out junior candidates:

1. how would you add a user to your system?  
If the candidate answers SAM, Sysadmin, Smit, /usr/ucb/vipw,
or any other type of sys admin tool, then ask them "What files get modified?"

Answer:
just /etc/passwd on most systems.
/etc/passwd and /etc/shadow in Solaris

2. What files are used to configure DNS on a Unix box 
/etc/resolv.conf and /etc/nsswitch.conf

3. What happens when the system boots? 
Answer should include something about the /etc/rc?.d scripts 
(/etc/rc1.d, /etc/rc2.d, /etc/rc3.d).  Some systems still use /etc/rc.local
(SunOS and HP-UX) or /sbin/rc[0-3].d scripts (Digital Unix) 

4. Where would you look for startup and error messages on a Unix server?
/var/adm/messages (/usr/adm/syslog on HP-UX boxes).  They can also run
the command dmesg.

5. What are some shells you'd find on a Unix box?
Answer should include at least: Bourne shell (sh), C-Shell (csh) and
Korn shell (ksh).  Might also mention Tom's C shell (tcsh), Bourne-again
shell (bash), or z-shell (zsh).

6. What are some other common unix scripting "languages?"
Looking for sed, awk, perl, tcl/tk, etc

7. What are the standard editors on a Unix system?
ed and vi.  Others are emacs and pico (these are becoming more and
more part of a standard unix distribution these days)

8. What common unix utility do you use to compile complex C programs?
Answer: make.  

9. How would you find the most recently changed file in a directory?
ls -latr or ls -ltr, then see which files are at the end of the list
or
ls -lat or ls -lt and see which are at the top of the list

(the t option of ls lists files by timestamp).

10. How do you mount a file system to make its files available to users
on a system?  
edit /etc/vfstab, add a line containing the physical disk the filesystem
is located on and the directory name you want to mount the filesystem to.

Followup: Explain the difference between vfstab and mnttab
/etc/vfstab is edited by the Sysadmin
/etc/mnttab is system-generated

11. How would you find all the processes being run by user "joe?"

System 5: ps -fe | grep joe
Berkeley: ps -auxww | grep joe